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Getting $tarted
The PowerPoint Window
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Quiclc Access Toolbar - contains shortcuts for the most
commonly used tools.
Backstage View - contains tools to work with workbook files
and manage Word settings.
Ribbon - contains groups of tools for use with Word 2010.
Slides and Outline thbs - display slide thumbnails or slide
outlines.
Slide Pane - displays the selected slide.
Notes Pane - displays notes for the selected slide.
Tab Bar - contains tabs that display tools and commands in
the ribbon.
Status Bar - contains document information and shortcuts.

nr@ Customizing the Ribbon
l. Click on the File tab.
2. Select Options in the left pane.
3. Select Customize Ribbon.
4. Click the arrow on the Customize the Ribbon box and select

the tab group you want to customize from the resulting menu.
5. Do any of the following:

. To hide or display a tab, check or clear the box next to the
group name in the box on the right.

. Tb rename a tab or group, select the current name and click
the Rename button. Enter a new name in the Display name
box and click the OK button.

. Tb rearrange tabs and groups, select the tab or group name
and click the Move Up H or Move Down frr',:l button.

6. Click the OK button when you are finished.

Opening a Presentation
1. Click on the File tab.
2. Select Open in the left pane.
3. In the Open dialog box, locate and select the file you want to

open.
4. Click the Open button.

Opening a Recent Presentation
1. Click on the File tab.
2. Select Recent in the left pane.
3. Do one of the following:

. To open a recent document, select the document in the
Recent Presentation pane.

. To open a recent folder, select the folder in the Recent Places
pane. Select the file you want to open and click the Open
button.

Creating a New Blanlc Presentation
1. Click on the File tab.
2. Select New in the left pane.
3. Select Blank presentation in the Available Templates and

Themes pane.
4. Click the Create button.

Creating a Presentation from a Template
1. Click on the File tab.
2. Select New in the left pane.
3. Do one of the following:

. Tb use a recently used template, select Recent templates.

. Tb use a sample template, select Sample templates.

. Tb use a template that you haue created, select My
templates.

4. Select the template you want to use.
5. Click the Create button.
Note: Click the Home button to retum to the Auailable Templates
pane.

Creating a Presentation Based on an
Office.com Template
1. Click on the File tab.
2. Select New in the left pane.
3. Select a template category in the Office.com Templates section.
4. Select the template you want to use.
5. Click the Download button.

$avingi a Presentation
f . Click on the File tab.
2. Do one of the following:

. To saue the document as a PowerPoint 2007 or PowerPoint
2010 file (.pptx), select Save from the left pane.

. To saue the document as another file format, select Save As
in the left pane. Click the arrow on the Save as type box and
select a format from the resulting menu.

Select the location where you want to save the document.
Enter a file name in the File name box.
Click the Save button.
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nrw) Using the Baclrstage View
- The Backstage view replaces and expands on the File menu in

PowerPoint 2003 and the Microsoft Office button in PowerPoint
2007. The Backstage view allows you to quickly manage
PowerPoint settings, such as Permissions, Sharing, Versions,
Properties, and Options. It also allows you to save a file, open a
file, or print the current file. To access the Backstage view, click on
the File tab on the Tbb Bar. Make selections in the Left pane. Click
on a tab (including the File tab) to exit the Backstage view.
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Slides
Creatingl a New Slide
1. Select the slide in the Slides tab that you want the new slide to

appear after.
2. Click on the Home tab.
3. Do one of the following:

. To insert a new slide with the same lagout as the selected
slide, click the top section of the New Slide button in the
Slides group.

. Tb insert a new slide with a different lagout, click the bottom
section of the New Slide button in the Slides group and
select a slide layout from the resulting menu.

Note: To quicklg create a new slide with the same lagout, click
below the slide in the Slides tab andpress the Enter keg.

Copying a Slide
1. Select the slide in the Slides tab that you want to copy.
2. Click on the Home tab.
3. Click the Copy button in the Clipboard group.
4. Click in the Slide tab where you want to place the new slide.
5. Click the top section ofthe Paste button in the Clipboard

group.
Note: To moue a slide, click and drag the slide thumbnail in the
Slides tab.

Deleting a Slide
1. Right-click the slide in the Slides tab that you want to delete.
2. Select Delete Slide from the shortcut menu.
Note: You can also select the slide in the Slides tab that gou want
to delete and press the Delete keg.

Changing the Layout of a Slide
1. Select the slide in the Slides tab that you want to change the

layout of.
Click on the Home tab.
Click the Layout button in the Slides group.
Select a layout from the resulting gallery. Qf you do not want
a defined lagout, select Blanh.)

Hiding a Slide
You can hide a slide so that it does not appear during a slide show
without deleting it from the presentation.
l. Select the slide in the Slides tab that you want to hide.
2. Click on the Slide Show tab.
3. Click the Hide Slide button in the Set Up group. (The hidden

slide icon will appear on the page number in the Slides tab.)

Working with Slide Views. To uiew tbg presentation in the default editing uiew, clickthe
Normal i.$jbutton on the Status Bat.

. To uiew the slides as thumbnails, click the Slide Sorter $E;
button on the Status Bar.

. Tb reuiew the presentation with simple editing g_o;4trols (not a
full screen slide show), click the Reading View i.@ button on
the Status Bar. Press the Esc key to exit Reading Mew.

. To_uiew the presentation as a slide show, click the Slide Show
l'F) button on the Status Bar. Press the Esc key to exit the
slide show. frfiffih-r-L -nr r.Jl

Note: You can also click on the View tab
and click the buttons in the Presentotion
Views group.
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Changing Slide Properties
1. Click on the Design tab.
2. Click the Page Setup button in the

Page Setup group.
3. Optional: Click the arrow on the Slides

sized for box and select a size from the
resulting menu.

4. Optional: Enter or select a number in the Number slides from
box.

5. Optional: Make changes in the Orientation section.
6. Click the OK button.
Note: Tb quicklg change the orientation ofslides, click on the
Design tab, click the Slide Orientation button in the Page Setup
group, and select an orientation from the resulting menu.

Adding a Header and Footer to a Slide
1. Select the slide in the Slides tab that you want to add a header

and footer to.
2. Click on the Insert tab.
3. Click the Header & Footer button in the Text group.
4. Do any of the following:

. To add the date and time, check the Date and time box and
select options.

. To add the slide number, check the Slide number box.

. Tb add footer text, check the Footer box and enter text in the
text box.

5. Optional: To prevent the header and footer from being displayed
on the title slide, check the Don't show on title slide box.

6. Optional: To add a header and footer to notes and handout
pages, click on the Notes and Handouts tab, make selections,
and click on the Slide tab.

7. Do one of the following:
. To applg the header and footer to the selected slide onlg,

click the Apply button.
. To applg the header and footer to all slides, click the Apply

to All button.

Themes
Applyin€ a Theme
1. Click on the Design tab.
2. Select a theme in the Themes group. (If the theme gou want is

not displaged, click the More button and select a theme from
the resulting gallery.)

Note: You can also apply a theme from the Backstage uiew. Click
on the File tab and select New in the Left pane. Select Themes,
select a theme, and click the Create button.

Applying a Color, Font, or Effects Scheme
1. Click on the Design tab.
2. In the Themes group, do any of the following:

. To applg a color scheme, clickthe Colors button and select a
color scheme from the resulting menu.

. To applg a font scheme, click the Fonts button and select a
font scheme from the resulting menu.

. To applg an effects scheme, click the Effects button and
select an effects scheme from the resulting menu.

Saving a Theme
1. Click on the Design tab.
2. Click the More button in the Themes group.
3. Select Save Current Theme from the resulting menu.
4. Enter a name for the theme in the File name box.
5. Click the Save button.
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Text
Creating a Text Box
l. Click on the Insert tab.
2. Click the Text Box button in the Text group.
3. Click and drag in the slide to create the text box.
4. Optional: To move a text box, place your mouse pointer over

the border of the box until it changes into a four-sided arrow.
Click and drag to move the text box.

5. Enter text in the text box and click outside the text box when
you are finished.

Note: Tb formot the text or text box, make selections on the
Format tab.

Adding Notes tq"a Slide
t. Click the Normal iffi-ibutton on the Status Bar.
2. Click in the Notes pane to enter text.
Note: To uiew notes in the Notes Poge uiew, click on the View
tab and click the Notes Poges button in the Presentation Views
group.

Usingi AutoFit
PowerPoint's AutoFit feature automatically resizes placeholder text to
keep it within the placeholder boundaries. If you don't want the text
to be resized, click the AutoFit Options ;* 'i button and select Stop
Fitting Text to This Placeholder from the resulting menu.
Note: Tb disable autofit for a placeholder, select the text in the
placeholder. Right-click the text and select Format Tert Effects
from the shortcut menu. Click the TErt Box button, select Do not
Autofit, and click the Close button.

Cutting, Gopyinfi, and Pasting Text
1. Select the text you want to cut or copy.
2. Click on the Home tab and do one of the following:

. To cut the text, click the Cut button in the Clipboard group
or press Ctrl + X.

. To copy the text, click the Copy button in the Clipboard
group or press Ctrl + C.

3. Click where you want to paste the selection.
4. Click the top section of the Paste button in the Clipboard

group or press Ctrl + V.
5. Optional: Click the Paste Options smart tag button that

appears and do one ofthe following:
. To keep the source formatting, click the Keep Source

Formatting W button.
c Tb merge the source and destination formatting, click the

Merge Formatting Si button.
. To paste the text with no formatting, click the Keep Text

only,ffi button.
Note: You con also preuiew screen shots and other graphics before
pasting them in your slides.

Text
Formatting
Applying Text Formattingf
1. Select the text you want to format.
2. Click on the Home tab.
3. Click the Show the Font dialog box launcher n' in the

bottom-right corner of the Font group.
4. Make font formatting selections.
5. Click the OK button when you are finished.
Note: Tb quicklg format selected text, click the buttons in the
Font group.

Applying Paragraph Formattinf
1. Select the text you want to format.
2. Click on the Home tab.
3. Click the Show the Paragraph dialog box launcher rl in the

bottom-right corner of the Paragraph group.
4. Make paragraph formatting selections.
5. Click the OK button when you are finished.
Note: To quicklg format selected text, click the buttons in the
Paragroph group.

Applying a WordArt Style to Text
1. Select the text you want to apply a style to.
2. Click on the Format tab.
3. Select a style in the WordArt Styles box. (If the stgle gou want

is not displaged, click the More button and select theme from
the resulting menu.)

Creatin{ a Bulleted or Numbered List
1. Click in the text box where you want to create the bulleted or

numbered list.
Click on the Home tab.
In the Paragraph group, do one ofthe following:
. To create a bulleted list, click the Bullets button.
. To create a numbered list, click the Numbering button.
Enter list text and press the Enter key after each line.
Optional: To create a multi-level list, select the list item you
want to promote or demote and click the Decrease List Level
or Increase List Level button in the Paragraph group.
When you are finished, click the Bullets or Numbering button
in the Pangraph group.

Note: Tb add bullets or numbering to existing text, select the text
gou want to make into a list. Click on the Home tab, and click the
Bullets or Numbering button in the Paragraph group.

Worlcing r,uith the Mini Toolbar
1. Select the text you want to format.
2. Place your mouse pointer over the Mini toolbar to display it.
3. Click a button on the Mini il;iliilli't a- j i= E= r & r

toolbar to format text. n r ig1= = o .;A _ Z-, Ja4
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ntw) Previewing Text Before Pasting
You can preview copied text to view the formatting before you
paste it in.
1. Copy the text you want to paste into the presentation.
2. Click on the Home tab.
3. Click the bottom section of the Paste button in the Clipboard

group.
4. Rest your mouse pointer on the buttons to preview the text

before you paste it.
5. Click a button to paste the text.
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lllustrations
lns€rtinE a Shape
lL CI-'ck on the Home tab.
A. Cick the Shapes button in the Drawing group.
E Select the shape you want from the resulting menu.
{. Cick and drag in the slide to create the shape.
E thtionol: To edit the shape, click on the Format tab that

rtrF€ars and click the buttons in the Shape Styles group.

trnsertingi an IllustratiCIn
l" Click in the slide where you want to insert the illustration.
!. Click on the Insert tab.
!t [n ttre Illustrations group, do one of the following:

. To insert a picture from a file, click the Picture button.
tr-ocate and select the graphic file you want to insert and click
the Insert button.

. Ta insert o clip art graphic, click the Clip Art button. Enter a
liepvord for the clip art you want to insert in the Search for
hor in the Clip Art task pane. Click the Go button. Click once
on the graphic you want to insert in the results pane.

. To insert a SmartArt graphic, click the SmartArt button.
Select a category in the left pane and select the SmartArt
graphic you want to insert. Click the OK button.

. To insert a chart, click the Chart button. Select a category
in the left pane and select the chart you want to insert. Click
the OK button. Enter chart data and click the Close button
lrhen you are finished.

Inserting Screen Shots
F,.r'r'erPoint now provides tools for taking screen shots (or pictures
:r the screen) and inserting them in your presentations. you can
:ke a screen shot of any window that is not minimized. If you
'$?.nt to insert a portion of a window, minimize all windows except
--ne PowerPoint window you are working in and the window you
'n"nt to use to take the screenshot.
I. Click the slide where you want to add the screenshot.
2. Click on the Insert tab.
3. Click the Screenshot button in the Illustrations group.
{. Do one of the following:

. To insert the whole window, click on a thumbnail in the
Available Windows gallery.

. To insert part of a window, select Screen Clipping. When the
mouse pointer becomes a cross, click and drag across the
area you want to capture.

5. Optional: Click the buttons on the Format tab that appears to
format the screen shot.

Applying Artistie Effects
You can apply artistic effects and textures, such as pencil sketch
and watercolor sponge, to pictures.
l. Click on the picture you want to apply the effects to.
2. Click on the Format tab.
3. Click the Artistic Effects button in the Adjust group.
1. Optional: Rest your mouse pointer over an effect to see the

"Live Preview" of the effect.
5. Select the effect you want to apply from the resulting gallery.
6. Optional: To apply a different artistic effect, click the Artistic

Effects button and select a different effect from the resulting
gallery.

Note: To remoue an artistic effect, click on the picture with the
effect gou want to remoue. Click on the Format tab, click the
Artj;tic Effects button, and select None from the resulting
gallery.

Removing thc Baekgreund
fronr a Picture (rwr
f . Click on the pictur-you want to remove

the background from.
Click on the Format tab.2,

aD.

4.
Click the Background Removal button in the Adjust gyoup.
Click and drag a handle on the box that appears ind drag ihe
line so that the box contains the portion of the picture you
want to keep.
Optional: For more precise selection, do any of the following in
the Refine group:
. To specify the parts of the picture gou do not want remoued,

click ivlark Areas to Keep. Click and drag lines to select the
areas to keep.

. To specifg the parts of the picture gou want remoued, click
Mark Areas to Remove. Click and draEi lines to select the
areas to remove.

. To remoue a line, click the Delete Mark button.
In the Close group, do one of the following:. To keep your changes, click the Keep Changes button.. To discard your changes, click the Discard All Changes

button.

D.
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As!!mration
Applying a Transiticn Effeat
1. Select the slide in the Slides tab you want to apply a transition

effect to.
Click on the Animations tab.
Select a transition in the Transition to This Slidebox. (If the
transition gou want is not displayed, click the More button
and select a theme from the resulting gallerg.)
Make additional selections in the Transition to This Slide box.
Optional: To preview the transition effect, click the preview
button in the Preview group.

Anirnatingi an Sbjeet
l. Select the object you want to animate.
2. Click on the Animations tab.
3. Select an animation in the Animation

Styles box in the Animations group. (1/
the animation you want is not displaged,
click the More button and select an
animation from the resulting galleru.)

4. Select an animation from the resulting
gallery.

5. Optional: To add an additional animation,
click the Add Animation button in the
Advanced Animation group and select an animation from the
resulting gallery.

6. To preview the animation(s) on the slide, click the top section
of the Preview button in the Preview group.

Note: To remoue animation from an object, click the More button
and select None from the resulting gailery.

Duplicatirag Acrimated Effeets (rwr
Use the Animation Painter to copy text animition effects.
f . !91e9t the object with the animation effect(s) you want to copy.
2. Click on the Animations tab.
3. Click the Animations Painter button in the Advanced

Animation group.
4_. Select the object you want to copy the animation effect(s) to.
Note: Double-click the Animation Painter button to apply effects
to more than one object. Ctick the Animotion pointeibitton
again to disable the Animation Painter.
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Slide Shows
Viewing a Slide Show

Click on the Slide Show tab.
In the Start Slide Show group, do one of the following:
. To start the slide show from the beginning, click the Slide

Show From Beginning button.
. To start the slide show from the current slide, clickthe From

Current Slide button.
3. Place your mouse pointer in the bottom-left corner of the slide

show and use the Slide Show toolbar to navigate throu€h the
slide show. (To exit the show before it is finished, press the Esc
keu')

4. Optional: To turn your mouse pointer into a laser, hold the
Ctrl key and click and drag the mouse pointer around in the
slide.

Note: Press FI during the show for a list of kegboard commands.
Click the OK button when you are finished.

Rehearsing Timings
Use the rehearse timings feature to record the time you will need
to present each slide in the slide show.
t. Click on the Slide Show tab.
2. Click the Rehearse Timings button in the Set Up group. (The

show will start in rehearsal mode and the Rehearsal toolbar
will be displaged. The Rehearsal toolbar displags the time for
the current slide and the entire presentation.)

3. When you are ready to advance to the next effect or slide, click
the Next button on the Rehearsal toolbar.

4. Repeat for all slides in the presentation.
5. When you are finished, do one of the following:

. Tb saue the timings, click the Yes button.

. To discard the timings, click the No button.

Settingi Up a Slide Show
Setting up a slide show allows you to set slide show options such
as the show type, which slides to include in the show, and how
to advance the slides. You can also
change the laser pointer color.
l. Click on the Slide Show tab.
2. Click the Set Up Slide Show

button in the Set Up group.
3. Make selections in the Set Up

Show dialog box.
4. Click the OK button when you

are finished.

Output
Printing Slides
1. Click on the File tab.
2. Select Print in the left pane. (The Print Preuiew is

automaticallg displayed in the right pane.)
3. Optional: To change the preview zoom, click and drag the

Zoom slider or click the Zoom Out or Zoom In buttons at the
bottom of the preview.

4. Optional: To print a single slide or rangie of slides, enter the
slide number or range in the Slides box in the middle pane

under Settings. (Bg default all slides will be printed unless gou
specifg the slides.)

5. Optional: Select print options in the middle pane.

6. Click the Print button to print the slide(s).
Note: You can also press Ctrl + P.

Printing Handouts, Notes
PaSles, or an Outline
1. Click on the File tab.
2. Select Print in the left pane.
3. Under Settings, click on Full Page Slides in

the middle section and do one of the following:
. Tb print handouts, select a handout layout from the resulting

menu.
. Tb print notes pages, select Notes Pages from the resulting

menu.
. To print an outline, select Outline from the resulting menu.

4. Click the Print button.

Savingi Handouts in a Word Document
f . Click on the File tab.
2. Select Save & Send in the left pane.
3. Under File Types, click Create Handouts.
4. Click the Create Handouts button.
5. Select a page layout in the Pagie layout in Microsoft Word

section.
6. Select Paste or Paste linls in the Add slides to Microsoft Word

document section.
7. Click the OK button.

E-mailing a Presentation
l. Click on the File tab.
2. Select Save & Send in the left pane.
3. Click the Send as Attachment button.
4. Enter recipient information in the To box.
5. Optional: Enter additional information.
6. Click the Send button.

Savingi a Presentation as a Video (rwr
You can save your presentation as a Windows Media Video (.wmv)
file, including voice narrations, transitions, animations, and
embedded audio and videos.
1. Click on the File tab.
2. Select Save & Send in the left pane.
3. Under File Types, click Create a Video.
4. Optional: Select options for the video in the right pane.
5. Click the Create Video button.
6. Enter a file name in the File name box.
7. Select a location to save the video.
8. Click the Save button.

Broadcasting a Slide Show (ewr
You can now broadcast your slide show to-.-a remote audience over
the Internet.
1. Click on the Slide Show tab.
2. Click the Broadcast Slide Show button in the Start Slide

Show group.
3. Click Start Broadcast. (You must haue a Windows Liue ID to

use this seruice.)
4. Login using your Windows Live ID login and password.
5. To share the unique URL for the slide show, do one of the

following:
. To send the URL bg e-mail, click on Send in Email.
. To copg the link, click on Copy Link.

6. When the audience has received the URL for the show, click
the Start Slide Show button.

7. When you are finished, press the Esc key to exit the Slide
Show and click the End Broadcast button in the Broadcast
group.

8. Click the End Broadcast button in the dialog box that appears.
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wing: z. 3ltHTf,J.t;row on the search button and select where you2., Dg one of the follo'

illiftiriilrii ,. z B1,ii"irf*+;ilin*;*;i,uiililo;li#**;#
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Browse Por,rrerPoint 2010 support section. __ 3. Do one of the followingi 
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buttons to nauigate through PowerPoint Help. 4. Click once on a topic to view Help information.

Prirrtin$ a-$.*lp lopic Accessing Help in the Backstage View (twrPrintin$ a Help Topic Accessing Help in the Backstage View (xtwt
l. Display the Help topic you want to print. Click on the File tab and select Help in the left pane. You-can
2. Click the Print & button on the Standard toolbar. access PowerPoint Help, Microsoft Office Online, or contact
3. Select print options. Microsoft Support.
4. Click the print button to print the topic. 
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